Connect with us

How to Make Incompatible Add-ons Work in Firefox 4


Firefox

How to Make Incompatible Add-ons Work in Firefox 4

Firefox 4 has been released by Mozilla with lots of new features like tabs on top. But one thing you might have noticed the moment you started using Firefox 4 is that add-ons from the previous versions are all incompatible. You might have installed lots of add-ons on your previous version and these will not work on Firefox 4.0 beta version. But you can easily bypass this check and make all the add-ons compatible with Firefox 4.

Firefox

If you open the add-ons page in your Firefox 4 (about:addons), you can see the incompatible add-ons.

Incompatible Add-ons

Open up the about:config page (type it in the URL bar and enter) and then right-click anywhere in the about:config page and choose New –> Boolean.

New boolean

Now in the pop up box enter the following values;

If you are using ;

  • 4.0 Beta- extensions.checkCompatibility.4.0b
  • 4.0 Release- extensions.checkCompatibility.4.0

Boolean Value

Set this value to false.

False value

Now you can make all your previously enabled add-ons to work with Firefox 4. All you need is to restart your browser. With this trick you can also install new add-ons which are still incompatible with latest version of Firefox.

Thanks to HowtoGeek for this tip.

Continue Reading
Advertisement

Nirmal is a Technology Blogger and a Microsoft MVP in Windows. He can be contacted at nirmal@nirmaltv.com. You can find Nirmal on , and .

6 Comments

6 Comments

  1. RNW

    July 8, 2010 at 6:09 pm

    when is the stable release of firefox 4

  2. Pingback: Firefox Update

  3. Pingback: Using Firefox 4 Portable with incompatible plug-ins made compatible! « ifsa.in

  4. random

    March 24, 2011 at 10:34 pm

    I didnt work for me, it still says its incompatible : (

  5. Pingback: Disable Add-on Compatibility Checks in All Versions of Firefox

  6. Sid

    June 26, 2011 at 2:02 pm

    Hello Nirmal,
    “extensions.checkCompatibility” hack did not work for me in firefox 5.0. I wanted to install aardvark in FF5 which is incompatible. I edited the addon file to make it work with firefox 5.0 and wrote a tutorial for needy users. May be it is useful for your readers too so posting a link here

    http://indigic.com/productivity/how-to-install-incompatible-addons-in-firefox-5-0/

    Hope it helps all who need it.
    Thanks

Leave a Reply

Your email address will not be published. Required fields are marked *

Recent Articles

Advertisement

Trending Articles

Latest in Windows 10

Subscribe to YouTube Channel

Like Us on Facebook

Sponsors

sponsors
To Top